Internet (skrótowiec od ang. inter-network, dosłownie "między-sieć") – ogólnoświatowa sieć komputerowa, określana również jako sieć sieci. W znaczeniu informatycznym Internet to przestrzeń adresów IP przydzielonych hostom i serwerom połączonym za pomocą urządzeń sieciowych, takich jak karty sieciowe, modemy i koncentratory, komunikujących się za pomocą protokołu internetowego z wykorzystaniem infrastruktury telekomunikacyjnej.
2. World Wide Web.
World Wide Web [ˌwɜːldˌwaɪdˈwɛb] (po angielsku: „ogólnoświatowa sieć”), w skrócie Web lub częściej WWW – hipertekstowy, multimedialny, internetowy system informacyjny oparty na publicznie dostępnych, otwartych standardach IETF i W3C. WWW jest usługą internetową, która ze względu na zdobytą popularność bywa błędnie utożsamiana z całym Internetem.
3. Zagrożenia przy pracy w internecie.
Uzależnienie, wirusy, kradzież danych osobowych
4. Uniform Resources Locator.
URL (ang. Uniform Resource Locator) – oznacza ujednolicony format adresowania zasobów (informacji, danych, usług) stosowany w Internecie i w sieciach lokalnych.
URL najczęściej kojarzony jest z adresami stron WWW, ale ten format adresowania służy do identyfikowania wszelkich zasobów dostępnych w Internecie.
Standard URL opisany jest w dokumencie RFC 1738.
5. Domain Name System.
Domain Name System (DNS, ang. system nazw domenowych) – system serwerów, protokół komunikacyjny oraz usługa obsługująca rozproszoną bazę danych adresów sieciowych. Pozwala na zamianę adresów znanych użytkownikom Internetu na adresy zrozumiałe dla urządzeń tworzących sieć komputerową. Dzięki DNS nazwa mnemoniczna, np. pl.wikipedia.org jest tłumaczona na odpowiadający jej adres IP, czyli 91.198.174.232
DNS to złożony system komputerowy oraz prawny. Zapewnia z jednej strony rejestrację nazw domen internetowych i ich powiązanie z numerami IP. Z drugiej strony realizuje bieżącą obsługę komputerów odnajdujących adresy IP odpowiadające poszczególnym nazwom. Jest nieodzowny do działania prawie wszystkich usług sieci Internet.
6. Host.
Host może oznaczać:
- Komputer podłączony do sieci komputerowej używającej protokołu komunikacyjnego TCP/IP, posiadający adres IP. Jeżeli użytkownik komputera łączy się z siecią komputerową, to karta sieciowa lub modem jego komputera otrzymuje adres IP i wtedy staje się hostem. W tym znaczeniu host jest dowolną maszyną, uczestniczącą w wymianie danych poprzez sieć komputerową, np. poprzez Internet.
- Komputer podłączony do sieci komputerowej łączem stałym, posiadający stały adres IP, udostępniający usługi sieciowe użytkownikom łączącym się z nim za pomocą swoich komputerów i umożliwiający im m.in. pracę w trybie terminalowym. Komputer użytkownika nazywany jest wtedy zdalnym terminalem, (ang.) remote terminal. Powszechną praktyką jest współistnienie na jednym hoście wielu usług, tj. obok usług umożliwiających pracę terminalową, np. telnet i SSH, także usług typu klient-serwer, najczęściej WWW i FTP. W tym znaczeniu, pojęcie host oznacza to samo co serwer, tym bardziej, że obecnie na większości tak rozumianych hostów, poza wewnętrznymi sieciami większych instytucji, usługi terminalowe, ze względów bezpieczeństwa, nie są dostępne.
- W publikacjach anglojęzycznych, termin host używany jest w określeniu "to host", czyli dostarczać infrastrukturę dla usług sieciowych. Przykładowo, wyrażenia: "to host Web server" lub "hosted by", mogą odnosić się do firmy zapewniającej sprzęt komputerowy, oprogramowanie oraz miejsce dla stron internetowych klienta.
7. Odsyłacze.
Hiperłącze (ang. hyperlink, inaczej: odnośnik, odsyłacz, link) – zamieszczone w dokumencie elektronicznym (tekstowym, graficznym, wideo, animacji, PDF, HTML) odwołanie do innego dokumentu lub innego miejsca w danym dokumencie. Odwołanie takie związane jest z fragmentem tekstu lub obrazem – uaktywnienie hiperłącza (kliknięcie lub nadejście odpowiedniego momentu) powoduje otwarcie dokumentu docelowego. Hiperłącza są powszechnie używane na stronach internetowych.
Koncepcja hiperłącza jest integralnie związana z pojęciem hipertekstu i pojawiła się już, jako idea, w pracach Paula Otleta przed II wojną światową; potem była sukcesywnie rozwijana w pracach Vannevara Busha, Teda Nelsona i Douglasa Engelbarta. Współcześnie koncepcja hiperłącza jest najbardziej znana z prac Tima Berners-Lee, jako podstawa WWW.
System hiperłączy pozwala na budowę złożonych dokumentów odwołujących się do rozmaitych źródeł – dobrym przykładem są tu aplikacje pakietów biurowych Microsoft Office czy Open Office. W pakietach biurowych hiperłącze, jako element hipertekstu, pojawiło się w pierwszej połowie lat 90., w wersji 6 dla DOS procesora tekstu WordPerfect, w którym można było wstawiać hiperłącza odwołujące się do innych miejsc w danym dokumencie lub do innych dokumentów WordPerfecta.
Hiperłączami w dokumentach procesorów tekstu są np. odwołania prowadzące od poszczególnych pozycji spisu treści, skorowidza, wykazu ilustracji i innych elementów aparatu naukowego w dokumencie do odpowiednich miejsc w treści tego dokumentu. Współcześnie stosuje się też hiperłącza prowadzące do witryn w Internecie.
8. Adres IP, maska sieciowa, Brama, serwery DNS.
Protokół internetowy (ang. Internet Protocol, skrót IP) – protokół komunikacyjny warstwy sieciowej modelu OSI (warstwy internet w modelu TCP/IP). Protokół internetowy to zbiór ścisłych reguł i kroków postępowania, które są automatycznie wykonywane przez urządzenia w celu nawiązania łączności i wymiany danych. Używany powszechnie w Internecie i sieciach lokalnych.
Dane w sieciach IP są wysyłane w formie bloków określanych mianem pakietów. W przypadku protokołu IP, przed rozpoczęciem transmisji nie jest zestawiana wirtualna sesja komunikacyjna pomiędzy dwoma hostami, które nie komunikowały się ze sobą wcześniej.
Protokół IP jest protokołem zawodnym – nie gwarantuje, że pakiety dotrą do adresata, nie zostaną pofragmentowane, czy też zdublowane, a ponadto mogą dotrzeć do odbiorcy w innej kolejności niż zostały nadane. Niezawodność transmisji danych jest zapewniana przez protokoły warstw wyższych (np. TCP), znajdujących się w hierarchii powyżej warstwy siecio
9. Dynamic Host Configuration Protocol (DHCP)
DHCP (ang. Dynamic Host Configuration Protocol – protokół dynamicznego konfigurowania węzłów) – protokół komunikacyjny umożliwiający komputerom uzyskanie od serwera danych konfiguracyjnych, np. adresu IP hosta, adresu IP bramy sieciowej, adresu serwera DNS, maski podsieci. Protokół DHCP jest zdefiniowany w RFC 2131 i jest następcą BOOTP. DHCP został opublikowany jako standard w roku 1993.
W kolejnej generacji protokołu IP, czyli IPv6, jako integralną część dodano nową wersję DHCP, czyli DHCPv6. Jego specyfikacja została opisana w RFC 3315.
W sieci opartej na protokole TCP/IP każdy komputer ma co najmniej jeden adres IP i jedną maskę podsieci; dzięki temu może się komunikować z innymi urządzeniami w sieci.
10. Wireless Application Protocol (WAP).
Wireless Application Protocol (WAP) – zbiór otwartych, międzynarodowych standardów definiujących protokół aplikacji bezprzewodowych. Rozwijaniem protokołu zajmuje się organizacja WAP Forum, będąca obecnie częścią Open Mobile Alliance (OMA). Wersja 1.0 protokołu powstała w 1998, 1.1 w 1999, a 2.0 w 2001 roku.
WAP został stworzony w celu umożliwienia dostępu do usług WWW, uwzględniając ograniczenia techniczne urządzeń mobilnych (np. PDA, telefon komórkowy) korzystających z tego protokołu, oraz ograniczeń łącza danych (które może być realizowane m.in. poprzez połączenie CSD lub GPRS).
Przy pomocy emulatora WAP można oglądać strony WAP na komputerze osobistym podłączonym do Internetu.
11. Cookies.
Plik cookie (ciasteczko) – niewielka informacja tekstowa, wysyłana przez serwer WWW i zapisywana po stronie użytkownika w pliku cookie (zazwyczaj na twardym dysku). Domyślne parametry ciasteczek pozwalają na odczytanie informacji w nich zawartych jedynie serwerowi, który je utworzył. Ciasteczka różnych rodzajów są stosowane najczęściej w przypadku liczników, sond, sklepów internetowych, stron wymagających logowania, reklam i do monitorowania aktywności odwiedzających.
Mechanizm ciasteczek został wymyślony przez byłego pracownika Netscape Communications – Lou Montulliego.
Popracuj nad dykcją!!!
OdpowiedzUsuń